[nmglug] usb drive

Ed Brown ebrown at lanl.gov
Wed Aug 16 11:10:32 PDT 2006

BrianO'Keefe wrote:

>> It seems a bit strange that when I ran ls in /media I see 2 
>> "For_Linux" where there has only been 1, as it should be. Is there 
>> just trouble with Linux and usb or is it me? 

I think you're getting very warm now.  There aren't 2 "For_Linux", 
there is 1 "For_Linux" directory/mount point, and one very large file, 
"For_linux", which probably accounts for your missing space and 
general confusion about what's going on.  (The linux operating system 
is case-sensitive about most things, so "Linux" != "linux".)

> brianokeefe at ubuntu:/media/For_Linux$ umount For_Linux
> umount: For_Linux is not mounted (according to mtab)
> brianokeefe at ubuntu:/media/For_Linux$ eject For_Linux
> umount: /media/For_Linux: device is busy
> umount: /media/For_Linux: device is busy
> Error: umount failed
> eject: unmount of `/media/For_Linux' failed

If you have any windows or other apps accessing/displaying/or 
otherwise using anything under /media/For_Linux, this is normal, to 
not be able to unmount that is.  I've never tried 'eject' with a USB 
device.  If you're sure you're not writing to the disk (external hard 
drive), you may be able to just unplug it (but I'm not sure about 
this, so best to unmount first if you can).


More information about the nmglug mailing list