[nmglug] Meeting tonight,

ABQLUG community at abqlug.com
Thu Aug 27 18:20:56 PDT 2020

Sorry I couldn't make it. I just finished working on the queue at my 
full time job.

UEFI and AHCI is what you want to use.

I also have had more luck by letting the distro automatically partition 
the hard drive. UEFI/EFI expects the /boot partition to be fat32. You 
would typically flag it as a EFI partition. I've setup it up plenty of 
times manually so I know it can work manually. But it doesn't sound like 
you tried /boot with fat32.

I try to install everything with UEFI. But some older machines that use 
"hybrid UEFI" (before UEFI was good). For those 12+ years old machines, 
I stick to the legacy BIOS. But only because I'm forced to.

Performance wise I don't think there is a real difference. With newer 
machines, there might be. My newest computer is a AMD bulldozer 8350 on 
an old ASUS Sabertooth motherboard.

There might be a time in the future where hardware will only work with 
UEFI. But if the older BIOS supports ACPI, then newer hardware shouldn't 
have issues with legacy BIOS.

The advice I have heard over the years was to avoid UEFI booting in 
favor of legacy BIOS. I think the big "fear" was the addition of secure 

I typically disable secure boot, unless it's a Ubuntu OS running. 
Secure boot is more or less of a joke, according to some of the research 
I've seen. And some of the less well known distros might not have access 
to the secure boot signing keys, so I just leave it off for them.

I typically recommend trying out UEFI with AHCI (not IDE or RAID) and 
leaving secure boot off. It's worked for me for years.

Also, the EFI shell is interesting. Theoretically if you know the right 
shell commands in EFI, you can get away without having any separate 
partition of EFI. (fat32)

~ Jared

On Aug 27 2020 10:23 AM, Ted Pomeroy wrote:
> I recently made some effort to take advantage of the UEFI settings
> for two laptops: I took a fresh Xubuntu 20.04 usb media and tried to
> install with UEFI support. Didn't work, "Partition table not good" 
> was
> the gist of the error. I tried a second usb of the same OS and 
> learned
> from it that I need a "Bios boot dedicated partition of at least 5
> GB." Aha, that helped, so I partitioned manually: bios=5Gb, 
> root=80Gb,
> home=150Gb and Swap=6Gb. This is where I forgot to give a mount point
> for the home partition, which I corrected later. Still wouldn't boot.
> So instead of panic, I tried Bios setting, first defaults which 
> didn't
> work, then adjusted Sata to ACHI, and finally under UEFI, turned that
> ON, and Presto!- Ubuntu appeared in the bios UEFI settings as my only
> UEFI sub-choice. Now it boots and the partitions match what the
> hardware expects.
> The result of my work put me back in touch with examining the BIOS
> settings and thinking through the options and deciding not to accept
> "Legacy mode" as the only or first choice. I wonder what the feelings
> of other Linux users are on this issue. What are the advantages of
> using the UEFI settings vs. the more easily booted "Legacy mode"?
> Ubuntu and Mint make the EFI system work quite well. Unless I am on 
> an
> even older machine why use the Legacy?
> Just a few thoughts to remind us of our NMLUG meeting tonight,  Aug.
> 27, 5:30-7:00. See the Virtual Meeting link for the Jitsi address at
> Nmglug.org  Thank you, Ted P
> _______________________________________________
> nmglug mailing list
> nmglug at lists.nmglug.org
> http://lists.nmglug.org/listinfo.cgi/nmglug-nmglug.org

More information about the nmglug mailing list